Getting started with SavaPage: questions and answers

@alfarizi The red X signals a non-secure Proxy Printer that no one can print to. See Proxy Printer List. You probably unchecked “Allow Non-Secure Proxy Print” in the Proxy Print options.

how to configuration time zone? because the timezone in the report invoice don’t same as with my timezone

@alfarizi The report shows the server’s time zone, not the client’s.

Thank you sir, this problem is solved

WhatsApp Image 2024-02-27 at 10.23.16

Hello Mr Rijkr.

I have a problem, after I added the Card Reader in the Devices menu,
Ip Address 192.168.10.8 in is the printer I use, before I configured the Add card Reader, the printer I used ran well and after I configured the Add card Reader the printer turned off and the status of the NFC Card I created was “Disconnected”. what do I have to do?

@alfarizi You’re on the wrong track. A Network Card Reader device runs the SavaPage Network Card Reader Service. Use the IP address of this device (with port number of the service) in the Network Card Reader dialog.

Hi there,

I recently installed SavaPage on Debian 12 in a Virtual Machine running on my file server. According to what I have read from the documentation, I think I have set it up correctly. But when I tried to connect to the Admin web portal, my browser said that “The site cannot be reached.” I tried accessing the web portal through my VM but it still came back with the same response. I have no idea on what I missed or set-up wrong. In the end I lust want to print from all devices in my home quickly and easily, without having to wrestle with printer drivers.

Thank you.

@GeorgeDaGreat Check the content of your /opt/savapage/server/logs/server.log … if it shows that SavaPage is up and running, your problem is outside the scope of SavaPage.

Hi again,

It turns out that the SavaPage service was not running at all when I tried connecting to the web portal. All I had to do was to start the service using systemctl start savapage, and after I did that, I was able to connect to the web portal, at last!

Thank you.

1 Like

Hello!

I installed and configured savapage on a VM Debian hosted on a Synology NAS

I followed the manual and I could almost complete all the steps. (struggled a bit with cups and samba config - section 2.3)

The printer is installed on Debian with a PS driver and it printed a test page
CUPS server is running, test page also ok
Printer is fully configured on the Savapage admin portal (ppd drivers downloaded on openprinting website) but I could not find a way to test from there…

I am able to receive the print in the savapage user web interface and send it to the proxy printer but nothing goes to the printer :frowning:

Savapage logs report everything is ok
print jobs are received in user web app → print jobs are sent to the printer → prints are completed
queue logs show also completed prints
CUPS logs show also completed jobs (btw : printer settings in CUPS show current connection is dnssd://printername_pdldatastream._tcp.local, is it normal ? shouldn’t it be some ipp address ?)

I changed the printer driver in CUPS printer config , by mistake I selected the PDF version instead of PS and now printer logs show ALSO completed prints

I was asking for help but managed to find the solution.

I leave this post, if it can help anyone else

@maurizio.aliquo Welcome to SavaPage and thanks for sharing your solution!

@rijkr Thank you Rick!

I just connected the user base to the Microsoft Active Directory and were able to import the user with their email but the “pager” and “employeeNumber” fields are not retrieved… is there something you can advice?

Cheers

@maurizio.aliquo I assume you mean LDAP fields for alternative authentication: “The ID and Card Number must each uniquely identify a user, so make sure that no two users have the same number. This means that the numbers defined in LDAP should be unique. If SavaPage encounters a non-unique ID or Card Number that user will not be updated.”

Card Number must be in HEX/LSB format. User ID number must have a minimum length (default = 4) that you can set as configuration property.

@rijkr Thanks again for your prompt reply :slight_smile:

definetely works with more than 4 characters, i am able to retrieve “employeeNumber” that fills “ID Number” in savapage!!

but now I am facing a frustrating issue…
I’ve been able to sync with AD the group “Domain Users” a few times during tests, and then it stopped.
(does not find any users in the group to update, according to sync logs)
I changed user source to “Domain Administrators” and it works for this group now, but no more with “Domain Users” , if you have any ideas ?

I backuped an earlier VM and was able to sync with “domain Users” again, but I am a bit fearing that this can reproduce in the future… I believe I could solve it by creating a new dedicated group that would work again…

@maurizio.aliquo As long as no errors are reported during User Sync it is hard to tell what causes your observation. Just to be sure, check /opt/savapage/server/logs/server.log for errors or warnings.

Beware: a User Sync results in “no action” if previously synced users in SavaPage are identical to the user source synced from.

I recommend to create a dedicated AD group called “SavaPage Users” to sync with. SavaPage supports nested AD groups, so you can include existing groups in this super group. See the User Creation section of the User Manual.

@rijkr Hello Rijk,

I will definetely use a dedicated sec. group! thank you

in the mean time I installed Postresql on the same host than savapage.
Database and user creation with roles went well but I am stucked with db-init (Manual - 21.2.5. Step 5 - Initialize new Database)

I get this error:
savapage@savapage :^~$ savapage-db --db-init
-bash: savapage-db: command not found

then I RTFM and opened the right folder (/opt/savapage/server/bin/linux-x64 and command was accepted but i got these 2 errors below…

ERROR - HHH000351 : could not read ot init a hi value
and
ERROR: relation “tbl_sequences” does not exist

I stopped savapage.service is reported as failed when I check his status, which seems ok. to perform these steps but now service status keeps “failed” even after a VM restart :frowning:

I think broke it :"(

I prefer asking you before I mess on another VM backup…

Thanks again for your help

@maurizio.aliquo Again the User Manual is your friend: see Migrating to an External Database with special attention to Step 4 - Change SavaPage Connection Parameters